Tw-city.info

IT Новости
1 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Как округлить до сотых в excel

Округление в Excel. Пошаговая инструкция

Округление чисел в Excel нужно для удобного форматирования, прогнозирования и коммуникации.

Существует множество способов округления, такие как округление до целого числа, округление в большую сторону, округление в меньшую сторону и т.д. В Excel мы можем округлять числа с помощью функций. Их мы и рассмотрим в этой статье.

Округление чисел в Excel с помощью изменения формата ячейки

Если вы хотите округлить числа исключительно с целью презентации, вы можете изменить формат ячейки, выполнив следующие шаги:

  • Кликнуть по ячейке с числовым значением;
  • Открыть меню форматирования ячейки с помощью сочетания клавиш CTRL+1 или кликнуть по ячейке правой кнопкой и в выпадающем списке выбрать пункт “ Формат ячеек “;
  • В всплывающем окне “ Формат ячеек ” перейти на вкладку “ Число “;
  • В разделе “ Числовые форматы ” кликнуть по пункту “ Числовой “;
  • В меню окна найти пункт “ Число десятичных знаков ” и указать точное количество знаков после запятой, которое вы хотите оставить;
  • Кликните по кнопке “ ОК ” для сохранения настроек форматирования.

Важно! Этот метод только визуально округляет число, не “отрезая” числа после запятой.

Округление в Excel с помощью функции ОКРУГЛ

Функция ОКРУГЛ часто используется в Excel для округления чисел. С ее помощью вы можете задать количество чисел после запятой.

Синтаксис

=ОКРУГЛ(число;число_разрядов)

Аргументы функции

  • число – числовое значение, которое вы хотите округлить;
  • число_разрядов – значение десятичного разряда, до которого вы хотите округлить первый аргумент функции.

Основы использования функции

  • если аргумент число_разрядовбольше “0”, то число округляется до указанного количества десятичных знаков. Например, =ОКРУГЛ(500,51;1) вернет “500.5”;
  • если аргумент число_разрядов равен “0”, то число округляется до ближайшего целого числа. Например, =ОКРУГЛ(500,51;0) вернет “501”;
  • если аргумент число_разрядовменьше “0”, то число округляется влево от десятичного значения. Например, =ОКРУГЛ(500,51;-1) вернет “501”.

Функция ОКРУГЛ работает на основе математического правила, по которому она определяет в большую или меньшую сторону следует округлить число:

  • Если число после запятой равно от 0 до 4, то округление будет произведено в меньшую сторону;
  • Если число после запятой равно от 5 до 9, то функция округлит в большую сторону.

На скриншоте ниже показаны примеры использования функции:

Округление в Excel в большую сторону с помощью функции ОКРУГЛВВЕРХ

Функция ОКРУГЛВВЕРХ округляет число в большую сторону, вне зависимости от того, какое число стоит после запятой.

Синтаксис

=ОКРУГЛВВЕРХ(число;число_разрядов)

Аргументы функции

  • число – числовое значение, которое вы хотите округлить;
  • число_разрядов – значение десятичного разряда, до которого вы хотите округлить первый аргумент функции.

Примеры использования функции ниже:

Округление в Excel в меньшую сторону с помощью функции ОКРУГЛВНИЗ

Функция ОКРУГЛВНИЗ округляет число в меньшую сторону, вне зависимости от того, какое число стоит после запятой.

Синтаксис

=ОКРУГЛВВНИЗ(число;число_разрядов)

Аргументы функции

  • число – числовое значение, которое вы хотите округлить;
  • число_разрядов – значение десятичного разряда, до которого вы хотите округлить первый аргумент функции.

На скриншоте ниже примеры использования функции:

Округление чисел в Microsoft Excel

Редактор таблиц Microsoft Excel широко применяется для выполнения разного рода вычислений. В зависимости от того, какая именно задача стоит перед пользователем, меняются как условия выполнения задачи, так и требования к получаемому результату. Как известно, выполняя расчёты, очень часто в результате получаются дробные, нецелые значения, что в одних случаях хорошо, а в других, наоборот, неудобно. В этой статье подробно рассмотрим, как округлить или убрать округление чисел в Excel. Давайте разбираться. Поехали!

Для удаления дробных значений применяют специальные формулы

О существовании специальной функции округления в Экселе знают далеко не все пользователи. Случается, что некоторые из них ошибочно принимают формат значений, то есть отображаемое количество знаков после запятой, за округление. Далее в статье разберёмся, что к чему и как всё делается.

Для начала отметим, что функция «Формат числа» применяется в случаях, когда вид числа необходимо сделать более удобным для чтения. Кликните правой кнопкой мыши и выберите в списке пункт «Формат ячеек». На вкладке «Числовой» установите количество видимых знаков в соответствующем поле.

Но в Excel реализована отдельная функция, позволяющая выполнять настоящее округление по математическим правилам. Для этого вам понадобится поработать с полем для формул. Например, вам нужно округлить значение, содержащееся в ячейке с адресом A2 так, чтобы после запятой остался только один знак. В таком случае функция будет иметь такой вид (без кавычек): «=ОКРУГЛ(A2;1)».

Принцип прост и понятен. Вместо адреса ячейки вы можете сразу указать само число. Бывают случаи, когда возникает необходимость округлить до тысяч, миллионов и больше. Например, если нужно сделать из 233123 — 233000. Как же быть в таком случае? Принцип тут такой же, как было описано выше, с той разницей, что цифру, отвечающую за количество разделов, которые необходимо округлить, нужно написать со знаком «-» (минус). Выглядит это так: «=ОКРУГЛ(233123;-3)». В результате вы получите число 233000.

Если требуется округлить число в меньшую либо в большую сторону (без учёта того, к какой стороне ближе), то воспользуйтесь функциями «ОКРУГЛВНИЗ» и «ОКРУГЛВВЕРХ». Вызовите окно «Вставка функции». В пункте «Категория» выберите «Математические» и в списке ниже вы найдёте «ОКРУГЛВНИЗ» и «ОКРУГЛВВЕРХ».

Ещё в Excel реализована очень полезная функция «ОКРУГЛТ». Её идея в том, что она позволяет выполнить округление до требуемого разряда и кратности. Принцип такой же, как и в предыдущих случаях, только вместо количества разделов указывается цифра, на которую будет заканчиваться полученное число.

В последних версиях программы реализованы функции «ОКРВВЕРХ.МАТ» и «ОКРВНИЗ.МАТ». Они могут пригодиться, если нужно принудительно выполнить округление в какую-либо сторону с указанной точностью.

Как вариант, решить проблему можно при помощи функции «ЦЕЛОЕ», принцип которой заключается в том, что дробная часть просто отбрасывается, округляя вниз.

Иногда программа автоматически округляет полученные значения. Отключить это не получится, но исправить ситуацию можно при помощи кнопки «Увеличить разрядность». Кликайте по ней, пока значение не приобретёт нужный вам вид.

Теперь, когда вы разбираетесь, как выполнять округление числа, вам будет проще выполнять ряд задач в программе. Кроме того, эти навыки помогут вам и в решении повседневных вопросов, связанных с расчётами.

Читать еще:  Как открыть несколько окон в excel

Если Excel округляет длинные числа

Если вы вставите в числовую ячейку длинное число с более, чем 15 разрядов, то Excel округлит его и выдаст нечто совсем непригодное. Например, число 893800399000003570 он покажет в виде 8,938E+17, а если по нему кликнуть, покажет его, как 893800399000003000. Здесь мы видим потерю последних трёх разрядов, что совершенно неприемлемо.

Решить проблему можно, если изменить формат ячейки или колонки с числового на текстовый. Тогда вставляемое число любой разрядности не будет преобразовываться. Также можно вставить его в числовую ячейку, если перед числом использовать знак одинарных кавычек.

Однако при преобразовании таких строчных записей в число Excel снова округляет все разряды больше 15-ти. Поэтому такой способ подходит лишь для представления больших чисел в таблице, а для вычислений они всё равно должны преобразовываться с потерями. Сделать с этим ничего нельзя – Excel так устроен, и 15 разрядов – предельная его точность, с которой можно записывать числа в таблице.

Пишите в комментариях были ли статья полезной для вас и продолжайте совершенствовать навыки работы в Microsoft Excel.

Как правильно округлить число в Excel и Google Таблицах: все способы с подробной инструкцией

К таблицам у всех нас разное отношение, кто-то их очень любит и “рисует” по каждому поводу, кто-то терпеть не может. Но всем нам иногда приходится с ними работать, поэтому полезно знать основные возможности табличного редактора и дополнительные фишки, например, закрепление строк, использование сортировки и фильтров. Такие инструменты могут здорово облегчить жизнь.

Сегодня же мы говорим о том, как округлить число в Excel, какие есть способы, для чего это нужно, и как правильно применять функции.

Способы

Под округлением каждый из нас может понимать что-то свое, поэтому давайте рассмотрим, какие варианты есть в Excel:

  1. Простое отбрасывание дробной части. Например, у нас есть число 12,3456, мы же хотим видеть только десятые и сотые доли, большая точность нас не интересует. Отбрасыванием дробной части мы получим результат 12,34. Такой способ часто используется для красоты, чтобы не перегружать таблицу и себя лишними знаками. В таком случае для решения задачи можно использовать формат ячеек.
  2. Математическое округление. В данном случае часть знаков после запятой отбрасывается, но при этом учитывается следующая цифра после значимого для нас разряда. Мы смотрим, она больше 5 или меньше. Например, у нас есть число 12,57. Мы хотим округлить его до десятых. Тогда по правилам математики мы получаем 12,6. То есть мы увеличили десятые доли на 1, потому что сотые больше 5. Если бы мы округляли 12,52, то получили бы 12,5.
  3. Округление до ближайшего большего или меньшего числа, так называемое округление “вверх” и округление “вниз” соответственно. Например, у нас есть исходные данные: 12,75, 12,31, 11,89, которые мы хотим преобразовать в целые величины. Если мы используем округление “вниз”, то получим 12, 12, 11. Если округляем в большую сторону, то получим 13, 13, 12.
  4. Округление до десятков, сотен, тысяч и так далее. Этот вариант бывает полезен, когда нам нужны приблизительные вычисления, без детализации.
  5. Округление до ближайшего четного и нечетного значения.
  6. Округление до ближайшего кратного какой-то величине числа. Например, у нас есть 124 конфеты, а в 1 коробку вмещается 13 конфет. И мы хотим понять, сколько конфет у нас разместится в коробках по 13 штук. Тогда мы будем округлять 124 до меньшего целого числа кратного 13 и получим результат 117.

Для каждого из этих случаев в Excel есть своя функция округления. Давайте научимся ими пользоваться. Но сначала посмотрим, как можно изменить внешний вид данных в таблице.

Формат ячеек

Часто нам нужно не фактическое округление, а просто аккуратный единый вид всех чисел в таблице. В таком случае мы не используем формулы, а просто меняем внешний вид данных.

Для этого выделяем ячейки в таблице и нажимаем правую кнопку мыши. В контекстном меню выбираем нужный раздел.

Во вкладке “Число” выбираем подходящий формат.

“Общий” используется по умолчанию и отображает данные в ячейках так, как они есть, изменить внешний вид тут не получится.

“Числовой” позволяет отображать столько знаков после запятой, сколько нужно, или вовсе убрать дробную часть.

“Денежный” и “Финансовый” похожи на “Числовой”, но позволяют также указывать валюту.

В “Процентном” тоже можно регулировать количество знаков после запятой. Если мы переключаемся на этот формат, то исходные данные в ячейках умножаются на 100, и добавляется значок %.

Я для своих вычислений чаще всего пользуюсь числовым форматом. Он универсальный и позволяет быстро привести ячейки к единому виду.

Этот способ подходит для Excel любого года выпуска. Если у вас новая версия программы, то решить задачу можно еще быстрее. Для этого во вкладке “Главная” есть специальный блок опций. Тут можно выбрать подходящий формат из выпадающего списка, а стрелочками влево и вправо увеличить или уменьшить количество разрядов.

Внимание: при изменении формата данных фактические значения в ячейках не меняются, они остаются прежними, просто отображаются по-другому.

Как работать с функциями в Excel

Мы рассмотрели самый простой способ убрать лишние знаки. Использовать его довольно удобно, если менять сами данные в таблице нам не нужно. Теперь мы переходим к использованию различных функций. Но сначала я хочу напомнить вам, что это такое, а также как с ними работать.

Функции ускоряют и упрощают вычисления. Например, нам надо посчитать сумму в столбце, в котором 100 значений. Мы можем делать это самым прямым способом “1+20+30+43…” и так 99 раз. Или написать встроенную команду “СУММ”, указать диапазон ячеек, и программа за секунду сделает расчеты.

Первый способ

Чтобы вручную написать формулу в ячейке с использованием функции, обязательно нужно:

  1. Поставить знак =.
  2. Правильно указать название.
  3. Открыть круглую скобку.
  4. Указать через точку с запятой аргументы, то есть данные, которые будут использоваться.
  5. Закрыть скобку.
Читать еще:  Как установить параметры страницы в word

Что может выступать аргументом математических формул:

Пример: функция “=СУММ(F21:F30)” посчитает сумму чисел, написанных в столбце F с позиции F21 до F30.

Эти правила нужно запомнить, иначе программа не сможет сделать вычисления, а будет выдавать ошибку такого вида.

Второй способ

Если неудобно писать команды вручную, то можно воспользоваться библиотекой, которая находится во вкладке “Формулы”.

Нас в данный момент интересуют математические операции. Нажимаем на соответствующий раздел и выбираем нужную процедуру.

Откроется диалоговое окно, в котором легко понять, какие аргументы нужно указать. Заполните поля и нажмите “ОК”.

Отбрасывание дробной части

Этот способ подойдет, если нам не важно, произойдет ли округление по математическим законам, и в какую сторону изменится значение. Когда мы просто хотим упростить вычисления, убрав лишние знаки, то можем отбросить их. Для этого есть функция “ОТБР”, которая содержит 2 параметра:

  • число, над которым нужно произвести действие;
  • количество знаков после запятой, которое следует оставить.

Например, у нас есть цена товара 4 716 рублей 77 копеек и еще уйма знаков после запятой. Логично отбросить все лишнее и получить только рубли и копейки.

Если же мы хотим получить только рубли без копеек, то вторым аргументом пишем не 2, а 0.

Математическое округление

Для привычного нам со школы математического действия есть специальная функция “ОКРУГЛ”. Она нужна для работы с дробными частями и целочисленными значениями. Аргументами выступают число и количество разрядов, которые нужно оставить после запятой.

Например, у нас есть значение 34,83021, и мы хотим округлить его с точностью до сотых. Тогда формула будет выглядеть так: “=ОКРУГЛ(34,83021;2)”.

Если в качестве второго аргумента указать 0, то получим целочисленное значение, то есть округлим первоначальные данные до единиц. А если количество разрядов будет отрицательным, то преобразовываться будет уже целое число.

Например, мы хотим округлить до сотен 1245,329. Тогда делаем такую запись в ячейке нашей таблицы: “=ОКРУГЛ(1245,329;-2)” и получаем результат 1 200.

В меньшую и большую сторону

Бывает так, что нам не нужно точное математическое вычисление, а важно не преувеличить или, наоборот, не уменьшить значение в ячейке. Тогда мы будем округлять в меньшую или большую сторону.

До дробных частей

Чтобы округлить в меньшую или большую сторону, есть универсальные функции “ОКРУГЛВНИЗ” и “ОКРУГЛВВЕРХ”. Они позволяют делать преобразования с точностью до целых и дробных частей.

Первый аргумент – это число, которое требуется округлить. Второй – количество разрядов. Если он больше 0, то показывает, сколько знаков после запятой должно остаться, если меньше 0, то происходит округление до десятков, сотен, тысяч. Если аргумент равен 0, то мы получаем точность до единиц, дробная часть отбрасывается.

Давайте посмотрим на примере работу этих двух команд.

До целых

Есть еще один способ округлить в меньшую или большую сторону. Для этого нам понадобятся функции “ОКРВНИЗ” и “ОКРВВЕРХ”. Они применяются для получения целочисленного результата.

Второй аргумент показывает, до какого разряда мы округляем:

  • 10 – до десятков;
  • 100 – до сотен;
  • 1 000 – до тысяч и т. д.

Показываю на примере.

Округление “вниз” до единиц можно заменить функцией “ЦЕЛОЕ”, у которой есть единственный аргумент – число. Результат будет таким же, как при использовании “ОКРВНИЗ”.

Округлить в большую сторону до ближайшего четного или нечетного целого значения помогают действия “ЧЁТН” и “НЕЧЁТ”. Пример использования одного из них вы видите на скриншоте.

До целых с учетом кратности

Помните пример с конфетами, который был в начале статьи? Сейчас мы научимся округлять до ближайшего кратного какой-то величине значения. Для этого служат 2 функции: “ОКРВНИЗ.МАТ” и “ОКРВВЕРХ.МАТ”. Первая уменьшает исходную величину, а вторая соответственно увеличивает.

Например, у нас есть число 124, и мы хотим округлить его до ближайшего большего кратного 5 значения. Тогда пишем в ячейке: “=ОКРВВЕРХ.МАТ(124;5)” и в результате получаем 125.

В Google Таблицах

Если вы любите работать в режиме онлайн, то можете задать формулу для округления данных в Google Таблицах.

Чтобы изменить формат ячеек, используйте опцию на основной панели инструментов.

Для уменьшения или увеличения разрядности также есть соответствующий инструмент.

Чтобы открыть перечень встроенных формул, нажмите на маленький черный треугольник рядом со значком суммы.

Чтобы округлить данные в ячейках, наводим курсор на математические функции и выбираем один из вариантов:

Работают они точно так же, как в Excel, но в Google Таблицах нет действий “ОКРВНИЗ.МАТ” и “ОКРВВЕРХ.МАТ”. Вместо них можно использовать “ОКРУГЛТ”, эта функция округляет до ближайшей кратной определенному числу величины. То есть в данном случае программа сама решает, в большую или меньшую сторону изменятся исходные данные.

Заключение

Мы рассмотрели все основные способы округления чисел в Microsoft Excel и Google Таблицах. Конечно, есть много частных случаев, которые требуют нетривиального решения. Если вы столкнулись с ситуацией, которая не описана в этой статье, напишите комментарий, и я постараюсь помочь и подсказать, как правильно составить формулу.

Microsoft Excel

трюки • приёмы • решения

Как в Excel округлять значения

Округление чисел — распространенная задача, и Excel предоставляет достаточно функций, которые округляют значения разными путями (табл. 111.1). Вы должны понимать разницу между округлением и форматированием значения.

Когда вы форматируете число так, чтобы оно отображало определенное количество знаков после запятой, формулы, которые ссылаются на это число, работают с его фактическим значением, которое может отличаться от отображаемого. Когда вы округляете числа, то формулы, которые ссылаются на эти значения, используют округленные числа.

Таблица 111.1. Функции округления Excel

В следующих разделах приведены примеры формул, которые используют различные типы округления.

Округление до ближайшего кратного числа

Функция ОКРУГЛТ полезна для округления значений до ближайших кратных. Например, вы можете использовать ее, чтобы округлить число до ближайшего, кратного 5. Следующая формула возвращает 135: =ОКРУГЛТ(133;5) .

Округление денежных значений

Часто приходится округлять валютные значения. Например, рассчитанная цена может оказаться равной 45,78923 р. В таком случае вы захотите округлить ее до ближайшей копейки. Этот процесс может показаться простым, но для округления значений такого типа вам предлагается на выбор один из трех следующих способов:

  • в большую сторону до ближайшей копейки;
  • в меньшую сторону до ближайшей копейки;
  • до ближайшей копейки (округление может быть или в большую, или в меньшую сторону).
Читать еще:  Номера страниц в word

Следующая формула предполагает, что значение рублей и копеек содержится в ячейке А1. Формула округляет значение до ближайшей копейки. Например, если ячейка А1 содержит 12,421 р., формула возвращает 12,42 р.: =ОКРУГЛ(А1;2) .

Если вам необходимо округлить значение в большую сторону до ближайшей копейки, используйте функцию ОКРВВЕРХ. Следующая формула, например, округляет значение в ячейке А1 до ближайшей копейки (если ячейка А1 содержит значение 12.421 р., формула возвращает 12,43 р.): =ОКРВВЕРХ(А1;0,01) .

Чтобы округлить рублевое значение в меньшую сторону, используйте функцию ОКРВНИЗ. Следующая формула, например, округляет такое значение в ячейке А1 в меньшую сторону до ближайшей копейки (если ячейка А1 содержит 12.421 р., то формула возвращает 12.42 р.): =ОКРВНИЗ(А1;0,01) .

Чтобы округлить рублевое значение до пяти копеек, используйте эту формулу: =ОКРВВЕРХ(А1;0,05) .

Использование функций ЦЕЛОЕ и ОТБР

На первый взгляд, функции ЦЕЛОЕ и ОТБР могут показаться похожими. Они обе преобразовывают значение в целое число. Функция ОТБР просто удаляет дробную часть числа. Функция ЦЕЛОЕ округляет в меньшую сторону до ближайшего целого числа, основываясь на значении дробной части числа.

На практике ЦЕЛОЕ и ОТБР возвращают разные значения только при использовании отрицательных чисел. Например, эта формула возвращает -14.0: =ОТБР(-14,2) .

Следующая формула возвращает -15,0, поскольку число -14,2 округляется в меньшую сторону до следующего целого числа: =ЦЕЛОЕ(-14,2) .

Функция ОТБР принимает дополнительный (необязательный) аргумент, который может быть полезен для усечения десятичных значений. Например, следующая формула возвращает 54,33 (значение усекается до двух десятичных знаков): =ОТБР(54.3333333;2) .

Округление до N значащих цифр

В некоторых ситуациях может понадобиться округлить значение до определенного количества значащих цифр. Например, вы хотите выразить число 1432,187 в терминах двух значащих цифр (то есть как 1400,000). Число 84 356 выражается в трех значимых цифрах как 84 300.

Если значение является положительным числом без десятичных знаков, то вам поможет следующая формула. Она округляет число в ячейке А1 до двух значащих цифр. Для округления до различного количества значащих цифр замените 2 в этой формуле нужным вам числом: =ОКРУГЛВНИЗ(А1;2-ДЛСТР(А1)) .

Для нецелых и отрицательных чисел решение будет немного более сложным. Следующая формула предлагает более общее решение, округляющее значение в ячейке А1 до количества значащих цифр, указанного в ячейке А2. Эта формула работает для положительных и отрицательных целых и нецелых чисел: =ОКРУГЛ(Al;А2-1-ЦЕЛОЕ(LOG10(ABS(А1)))) .

Например, если ячейка А1 содержит число 1,27845, а в ячейке А2 хранится 3, то формула вернет 1,28000 (значение, округленное до трех значащих цифр).

В ремонт металлических дверей замков входит починка дверных петель, коробок и полотен, которые с течением времени и из-за неправильного использования могут расклеиваться и перекашиваться. Бывает так, что они просто перестают плотно держаться в массиве, потому что их плохо прижимают шурупы, которые, в свою очередь, могут выходить из массива вследствие плохо нарезанной резьбы или сырой древесины, куда они были вкручены. В результате после усыхания материала отверстия стали шире и шурупы вышли из них.

ШКОЛА ПРОГРАММИРОВАНИЯ

Вы здесь

Сообщение об ошибке

Функции округления чисел в Excel

При работе с функциями в Excel, Вы наверно замечали набор функций ОКРУГЛ(), ОКРВВЕРХ(), ОКРВНИЗ(), ОКРУГЛВВЕРХ(), ОКРУГЛВНИЗ() категории «Математические». В чем отличия между этими функциями и как они работают?

Ранее, в статье «Формат данных в Excel», я описывал форматы представления данных в Excel. С помощью представления можно добавить или сократить дробную часть числа, но фактический формат числа остается неизменным. Часто, при делении чисел, дробная часть получается очень длинной, что в дальнейшем может мешать при некоторых расчетах и выдавать результат не тот, который ожидался. Для того чтобы сократить дробную часть числа (округлить), используется функция ОКРУГЛ(), в которой можно указать необходимое число разрядов после запятой. Также возможно округление и целой части.

Округление происходит следующим образом:
-Если число меньше 5, то следующий разряд остается неизменным.
-Если число равно или больше 5, то к следующему разряду добавляется единица.

Например, число 2553,5675643 после округления до сотых будет выглядеть 2553,57
В общем, округление по школьной программе 🙂

Теперь рассмотрим как работает функция ОКРУГЛ() и какие имеет аргументы.

Синтаксис функции прост — ОКРУГЛ(Число; Число разрядов).

  • Число – в этом аргументе указывается ссылка на ячейку с числом, которое необходимо округлить или вводите значение. Допускает использование других функции, результатом которых является число.
  • Число разрядов — значение этого аргумента указывает, до какого разряда необходимо округлить число. При указании в этом аргументе положительного числа, округление будет происходить после запятой. При нуле, округление до целой части. При указании отрицательного аргумента, округляется целая часть. При этом, кол-во разрядов в целой части, сохраняется и заполняется нулями.

Пример:
Округлим число 2553,5675643
Запись функции следующая:

«=ОКРУГЛ(2553,5675643;2)» вернет результат 2553,57
«=ОКРУГЛ(2553,5675643;0)» вернет 2554
«=ОКРУГЛ(2553,5675643;-2)» вернет 2600

В Excel так же есть функции ОКРВВЕРХ(), ОКРВНИЗ(), ОКРУГЛВВЕРХ(), ОКРУГЛВНИЗ(). Все эти функции практически аналогичны работе с функцией ОКРУГЛ(), но у каждой из них немного иной алгоритм округления.

Функция:
ОКРВВЕРХ() — функция округляет число до ближайшего целого, которое кратно числу, указанного в аргументе «точность«. Округление происходит в большую сторону.

Примеры:
«=ОКРВВЕРХ(2553,57;1)», результат 2554
«=ОКРВВЕРХ(2553,57;3)», вернет результат кратный 3 т.е. 2556

Для округления отрицательных чисел, аргумент «точность» должен быть также отрицательным, иначе функция вернет ошибку «#ЧИСЛО!»
«=ОКРВВЕРХ(-2553,57;-2)», результат -2554

И еще один пример округления, но уже дробного числа
«=ОКРВВЕРХ(0,578;0,02)» результат 0,58

ОКРВНИЗ() функция аналогична ОКРВВЕРХ(), с той лишь разницей что округление происходит в меньшую сторону.
«=ОКРВНИЗ(2553,57;2)» результат 2552

ОКРУГЛВВЕРХ(), ОКРУГЛВНИЗ() — функции по принципу работы схожи с функцией ОКРУГЛ(). Отличие в том, что эти функции округляют число с избытком(недостатком).

Примеры:
«=ОКРУГЛВВЕРХ(2553,34;1)», результат получится 2553,4
«=ОКРУГЛВВЕРХ(2553,34;-1)», результат 2560
«=ОКРУГЛВНИЗ(2553,34;1)», результат 2553,3
«=ОКРУГЛВНИЗ(2553,34;-1)», результат 2550

Ссылка на основную публикацию
Adblock
detector