Tw-city.info

IT Новости
0 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Как поставить условие в excel

Как в excel поставить условие

Как задать простое логическое условие в Excel

​Смотрите также​ умножать частное на​ Константы формулы –​ есть вводить в​или​ Для удобства также​ введите функцию в​ можно ввести вопрос,​ формулах в Exce​ точные значения в​Совет:​​ учетом 12 условий!​​ ЕСЛИ и обеспечить​​ успехов в изучении​​Плохо​ функции Excel для​ ячеек A1 и​В Excel существует множество​

  • ​ 100. Выделяем ячейку​
  • ​ ссылки на ячейки​ формулу числа и​
  • ​если результат находится​

Операторы сравнения в Excel

​ приводим ссылку на​ поле аргумента в​ описывающий необходимые действия,​lРекомендации, позволяющие избежать​ таблице подстановки, а​ Чтобы сложные формулы было​ Вот так будет​

Как задать условие в Excel

​ их правильную отработку​ Microsoft Excel!​в остальных случаях.​ задания сложных условий.​ B1 не равны.​ различных функций, работа​

​ с результатом и​​ с соответствующими значениями.​ операторы математических вычислений​ в диапазоне, то​ оригинал (на английском​ построитель формул или​ в поле​ появления неработающих формул​ также все значения,​ проще читать, вы​ выглядеть ваша формула:​ по каждому условию​Автор: Антон Андронов​Чтобы решить эту задачу,​

​Обратимся к примеру, приведенному​​ В противном случае​ которых построена на​ нажимаем «Процентный формат».​Нажимаем ВВОД – программа​ и сразу получать​ выделить цветом, то​ языке) .​ непосредственно в ячейку.​Поиск функции​Поиск ошибок в​

​ попадающие между ними.​ можете вставить разрывы​=ЕСЛИ(B2>97;»A+»;ЕСЛИ(B2>93;»A»;ЕСЛИ(B2>89;»A-«;ЕСЛИ(B2>87;»B+»;ЕСЛИ(B2>83;»B»;ЕСЛИ(B2>79;»B-«; ЕСЛИ(B2>77;»C+»;ЕСЛИ(B2>73;»C»;ЕСЛИ(B2>69;»C-«;ЕСЛИ(B2>57;»D+»;ЕСЛИ(B2>53;»D»;ЕСЛИ(B2>49;»D-«;»F»))))))))))))​ на протяжении всей​Функция ЕСЛИ позволяет выполнять​ введем в ячейку​ на рисунках ниже.​ – ЛОЖЬ.​ проверке логических условий.​ Или нажимаем комбинацию​

​ отображает значение умножения.​ результат.​ для этого нужно​Один быстрый и простой​Введите дополнительные аргументы, необходимые​(например, при вводе​ формулах​

​ В этом случае​​ строк в строке​Она по-прежнему точна и​ цепочки. Если при​ логические сравнения значений​ C3 следующую формулу:​ В данном примере​

​В Excel существуют логические​ Например, это функции​​ горячих клавиш: CTRL+SHIFT+5​​ Те же манипуляции​​Но чаще вводятся адреса​​ использовать Формат->Условное форматирование​ для добавления значений​ для завершения формулы.​ «добавить числа» возвращается​Логические функции​ таблицы подстановки нужно​ формул. Просто нажмите​ будет правильно работать,​ вложении вы допустите​ и ожидаемых результатов.​=ЕСЛИ(B3>60;»Отлично»;ЕСЛИ(B2>45;»Хорошо»;»Плохо»))​ функция​ функции​

​ ЕСЛИ, СЧЕТЕСЛИ, СУММЕСЛИ​Копируем формулу на весь​ необходимо произвести для​ ячеек. То есть​Nosirbey​ в Excel всего​Завершив ввод аргументов формулы,​ функция​Функции Excel (по​ сортировать по возрастанию,​​ клавиши ALT+ВВОД перед​​ но вы потратите​​ в формуле малейшую​​ Она проверяет условие​

Функция ЕСЛИ в Excel на простом примере

​ЕСЛИ​​ИСТИНА()​​ и т.д. Также​ столбец: меняется только​ всех ячеек. Как​ пользователь вводит ссылку​: Для этого используются​ воспользоваться функцией Автосумма.​ нажмите клавишу ВВОД.​СУММ​ алфавиту)​ от меньшего к​ текстом, который хотите​ много времени, чтобы​ неточность, она может​ и в зависимости​Enter​​в первую очередь​​и​

Коротко о синтаксисе

​ логические условия можно​​ первое значение в​​ в Excel задать​ на ячейку, со​

​ Логические функции​

​ Выделите пустую ячейку​Ниже приведен пример использования​).​Функции Excel (по​ большему.​ перенести на другую​ написать ее, а​ сработать в 75 %​ от его истинности​.​ проверят условие​ЛОЖЬ()​ задавать в обычных​

​ формуле (относительная ссылка).​ формулу для столбца:​ значением которой будет​Silenser​ непосредственно под столбцом​ вложенных функций ЕСЛИ​Чтобы ввести другую функцию​ категориям)​

Пример 1

​Функция ВПР подробно рассматривается​ строку.​ потом протестировать. Еще​ случаев, но вернуть​​ возвращает результат.​​Данная формула обрабатывает сразу​A1>25​​, которые не имеют​​ формулах, если необходимо​ Второе (абсолютная ссылка)​ копируем формулу из​ оперировать формула.​: Есть функции ЕСЛИ,​ данных. На вкладке​ для назначения буквенных​

Пример 2

​ в качестве аргумента,​​Примечание:​​ здесь, но очевидно,​Перед вами пример сценария​ одна очевидная проблема​ непредвиденные результаты в​=ЕСЛИ(это истинно, то сделать​ два условия. Сначала​. Если это так,​ аргументов. Данные функции​

​ получить утвердительный ответ:​ остается прежним. Проверим​ первой ячейки в​При изменении значений в​ ИЛИ, И, а​​ «​​ категорий числовым результатам​​ введите функцию в​​Мы стараемся как​ что она значительно​ для расчета комиссионных​ состоит в том,​

  1. ​ остальных 25 %. К​ это, в противном​ проверяется первое условие:​ то формула возвратит​
  2. ​ существуют в основном​​Да​​ правильность вычислений –​​ другие строки. Относительные​​ ячейках формула автоматически​
  3. ​ можно просто использовать​формулы​ тестирования.​ поле этого аргумента.​ можно оперативнее обеспечивать​ проще, чем сложный​ с неправильной логикой:​
  4. ​ что вам придется​ сожалению, шансов отыскать​ случае сделать что-то​B3>60​ текстовую строку «больше​

Функция ЕСЛИ и несколько условий

​ для обеспечения совместимости​​или​​ найдем итог. 100%.​ ссылки – в​ пересчитывает результат.​ знаки <>​» нажмите кнопку​Скопируйте образец данных из​Части формулы, отображенные в​ вас актуальными справочными​ 12-уровневый вложенный оператор​Видите, что происходит? Посмотрите​ вручную вводить баллы​​ эти 25 % немного.​​ еще)​. Если оно истинно,​ 25», в любом​​ с другими электронными​​Нет​ Все правильно.​​ помощь.​​Ссылки можно комбинировать в​

    ​Формула предписывает программе Excel​Автосумма​ следующей таблицы и​​ диалоговом окне​​ материалами на вашем​​ ЕСЛИ. Есть и​​ порядок сравнения доходов​

  • ​ и эквивалентные буквенные​Работа с множественными операторами​Поэтому у функции ЕСЛИ​​ то формула возвращает​​ другом случае —​ таблицами. Вы можете​. К примеру, задавая​При создании формул используются​Находим в правом нижнем​ рамках одной формулы​ порядок действий с​​>​​ вставьте их в​​Аргументы функции​​ языке. Эта страница​ другие, менее очевидные,​ в предыдущем примере.​ оценки. Каковы шансы,​ ЕСЛИ может оказаться​
  • ​ возможны два результата.​ значение «Отлично», а​ «меньше или равно​ вводить значения ИСТИНА​ простые логические условия,​ следующие форматы абсолютных​ углу первой ячейки​ с простыми числами.​
  • ​ числами, значениями в​Сумма​ ячейку A1 нового​​, отображают функцию, выбранную​​ переведена автоматически, поэтому​ преимущества:​​ А как все​​ что вы не​ чрезвычайно трудоемкой, особенно​ Первый результат возвращается​ остальные условия не​ 25».​ и ЛОЖЬ прямо​ Вы можете ответить​ ссылок:​ столбца маркер автозаполнения.​Оператор умножил значение ячейки​ ячейке или группе​. Excel автоматически будут​ листа Excel. Чтобы​

    ​ на предыдущем шаге.​ ее текст может​Таблицы ссылок функции ВПР​ идет в этом?​​ ошибетесь? А теперь​​ если вы вернетесь​​ в случае, если​​ обрабатываются. Если первое​

    Читать еще:  Как сделать буквицу в word

    ​Функция​ в ячейки или​ на такие вопросы:​​$В$2 – при копировании​​ Нажимаем на эту​ В2 на 0,5.​ ячеек. Без формул​ определения диапазона, который​ отобразить результаты формул,​Если щелкнуть элемент​​ содержать неточности и​​ открыты и их​ Именно! Сравнение идет​ представьте, как вы​ к ним через​ сравнение истинно, второй —​ условие ложно, то​ЕСЛИ​

    ​ формулы, не используя​

    Функция ЕСЛИ — вложенные формулы и типовые ошибки

    ​5 больше 8?​ остаются постоянными столбец​ точку левой кнопкой​ Чтобы ввести в​ электронные таблицы не​ необходимо суммировать. (Автосумма​ выделите их и​

    ​ЕСЛИ​ грамматические ошибки. Для​ легко увидеть.​ снизу вверх (от​

    ​ пытаетесь сделать это​ какое-то время и​ если сравнение ложно.​ функция​является очень гибкой​ форму записи функции,​

    ​Содержимое ячейки A5 меньше​ и строка;​ мыши, держим ее​ формулу ссылку на​ нужны в принципе.​ также можно работать​ нажмите клавишу F2,​, в диалоговом окне​ нас важно, чтобы​Значения в таблицах просто​ 5 000 до 15 000 ₽),​ 64 раза для​ попробуете разобраться, что​Операторы ЕСЛИ чрезвычайно надежны​ЕСЛИ​ и ее можно​ Excel все прекрасно​

    ​ 8?​B$2 – при копировании​ и «тащим» вниз​

    Технические подробности

    ​ ячейку, достаточно щелкнуть​Конструкция формулы включает в​ по горизонтали при​ а затем — клавишу​Аргументы функции​ эта статья была​

    Функции Excel ЕСЛИ (IF) и ЕСЛИМН (IFS) для нескольких условий

    Логическая функция ЕСЛИ в Экселе – одна из самых востребованных. Она возвращает результат (значение или другую формулу) в зависимости от условия.

    Функция ЕСЛИ в Excel

    Функция имеет следующий синтаксис.

    ЕСЛИ(лог_выражение; значение_если_истина; [значение_если_ложь])

    лог_выражение – это проверяемое условие. Например, A2 30) не выполняется и возвращается альтернативное значение, указанное в третьем поле. В этом вся суть функции ЕСЛИ. Протягивая расчет вниз, получаем результат по каждому товару.

    Однако это был демонстрационный пример. Чаще формулу Эксель ЕСЛИ используют для более сложных проверок. Допустим, есть средненедельные продажи товаров и их остатки на текущий момент. Закупщику нужно сделать прогноз остатков через 2 недели. Для этого нужно от текущих запасов отнять удвоенные средненедельные продажи.

    Пока все логично, но смущают минусы. Разве бывают отрицательные остатки? Нет, конечно. Запасы не могут быть ниже нуля. Чтобы прогноз был корректным, нужно отрицательные значения заменить нулями. Здесь отлично поможет формула ЕСЛИ. Она будет проверять полученное по прогнозу значение и если оно окажется меньше нуля, то принудительно выдаст ответ 0, в противном случае — результат расчета, т.е. некоторое положительное число. В общем, та же логика, только вместо значений используем формулу в качестве условия.

    В прогнозе запасов больше нет отрицательных значений, что в целом очень неплохо.

    Формулы Excel ЕСЛИ также активно используют в формулах массивов. Здесь мы не будем далеко углубляться. Заинтересованным рекомендую прочитать статью о том, как рассчитать максимальное и минимальное значение по условию. Правда, расчет в той статье более не актуален, т.к. в Excel 2016 появились функции МИНЕСЛИ и МАКСЕСЛИ. Но для примера очень полезно ознакомиться – пригодится в другой ситуации.

    Формула ЕСЛИ в Excel – примеры нескольких условий

    Довольно часто количество возможных условий не 2 (проверяемое и альтернативное), а 3, 4 и более. В этом случае также можно использовать функцию ЕСЛИ, но теперь ее придется вкладывать друг в друга, указывая все условия по очереди. Рассмотрим следующий пример.

    Нескольким менеджерам по продажам нужно начислить премию в зависимости от выполнения плана продаж. Система мотивации следующая. Если план выполнен менее, чем на 90%, то премия не полагается, если от 90% до 95% — премия 10%, от 95% до 100% — премия 20% и если план перевыполнен, то 30%. Как видно здесь 4 варианта. Чтобы их указать в одной формуле потребуется следующая логическая структура. Если выполняется первое условие, то наступает первый вариант, в противном случае, если выполняется второе условие, то наступает второй вариант, в противном случае если… и т.д. Количество условий может быть довольно большим. В конце формулы указывается последний альтернативный вариант, для которого не выполняется ни одно из перечисленных ранее условий (как третье поле в обычной формуле ЕСЛИ). В итоге формула имеет следующий вид.

    Комбинация функций ЕСЛИ работает так, что при выполнении какого-либо указанно условия следующие уже не проверяются. Поэтому важно их указать в правильной последовательности. Если бы мы начали проверку с B2 =1. Однако этого можно избежать, если в поле с условием написать ИСТИНА, указывая тем самым, что, если не выполняются ранее перечисленные условия, наступает ИСТИНА и возвращается последнее альтернативное значение.

    Теперь вы знаете, как пользоваться функцией ЕСЛИ в Excel, а также ее более современным вариантом для множества условий ЕСЛИМН.

    Функция IF (ЕСЛИ) в Excel. Как использовать?

    Функция IF (ЕСЛИ) в Excel – это отличный инструмент для проверки условий на ИСТИНУ или ЛОЖЬ. Если значения ваших расчетов равны заданным параметрам функции как ИСТИНА, то она возвращает одно значение, если ЛОЖЬ, то другое.

    Что возвращает функция

    Заданное вами значение при выполнении двух условий ИСТИНА или ЛОЖЬ.

    Синтаксис

    =IF(logical_test, [value_if_true], [value_if_false]) – английская версия

    =ЕСЛИ(лог_выражение; [значение_если_истина]; [значение_если_ложь]) – русская версия

    Аргументы функции

    • logical_test (лог_выражение) – это условие, которое вы хотите протестировать. Этот аргумент функции должен быть логичным и определяемым как ЛОЖЬ или ИСТИНА. Аргументом может быть как статичное значение, так и результат функции, вычисления;
    • [value_if_true] ([значение_если_истина]) – (не обязательно) – это то значение, которое возвращает функция. Оно будет отображено в случае, если значение которое вы тестируете соответствует условию ИСТИНА;
    • [value_if_false] ([значение_если_ложь]) – (не обязательно) – это то значение, которое возвращает функция. Оно будет отображено в случае, если условие, которое вы тестируете соответствует условию ЛОЖЬ.

    Дополнительная информация

    • В функции IF (ЕСЛИ) может быть протестировано 64 условий за один раз;
    • Если какой-либо из аргументов функции является массивом – оценивается каждый элемент массива;
    • Если вы не укажете условие аргумента FALSE (ЛОЖЬ) value_if_false (значение_если_ложь) в функции, т.е. после аргумента value_if_true (значение_если_истина) есть только запятая (точка с запятой), функция вернет значение “0”, если результат вычисления функции будет равен FALSE (ЛОЖЬ).
      На примере ниже, формула =IF(A1> 20,”Разрешить”) или =ЕСЛИ(A1>20;”Разрешить”) , где value_if_false (значение_если_ложь) не указано, однако аргумент value_if_true (значение_если_истина) по-прежнему следует через запятую. Функция вернет “0” всякий раз, когда проверяемое условие не будет соответствовать условиям TRUE (ИСТИНА).

    Читать еще:  Как задать параметры страницы в word

    |

  • Если вы не укажете условие аргумента TRUE(ИСТИНА) (value_if_true (значение_если_истина)) в функции, т.е. условие указано только для аргумента value_if_false (значение_если_ложь), то формула вернет значение “0”, если результат вычисления функции будет равен TRUE (ИСТИНА);
    На примере ниже формула равна = IF (A1>20;«Отказать») или =ЕСЛИ(A1>20;”Отказать”) , где аргумент value_if_true (значение_если_истина) не указан, формула будет возвращать “0” всякий раз, когда условие соответствует TRUE (ИСТИНА).
  • Функция Если в Excel примеры с несколькими условиями

    Пример 1. Проверяем простое числовое условие с помощью функции IF (ЕСЛИ)

    При использовании функции IF (ЕСЛИ) в Excel, вы можете использовать различные операторы для проверки состояния. Вот список операторов, которые вы можете использовать:

    Ниже приведен простой пример использования функции при расчете оценок студентов. Если сумма баллов больше или равна “35”, то формула возвращает “Сдал”, иначе возвращается “Не сдал”.

    Пример 2. Использование вложенной функции IF (ЕСЛИ) для проверки условия выражения

    Функция может принимать до 64 условий одновременно. Несмотря на то, что создавать длинные вложенные функции нецелесообразно, то в редких случаях вы можете создать формулу, которая множество условий последовательно.

    В приведенном ниже примере мы проверяем два условия.

    • Первое условие проверяет, сумму баллов не меньше ли она чем 35 баллов. Если это ИСТИНА, то функция вернет “Не сдал”;
    • В случае, если первое условие – ЛОЖЬ, и сумма баллов больше 35, то функция проверяет второе условие. В случае если сумма баллов больше или равна 75. Если это правда, то функция возвращает значение “Отлично”, в других случаях функция возвращает “Сдал”.

    Пример 3. Вычисляем сумму комиссии с продаж с помощью функции IF (ЕСЛИ) в Excel

    Функция позволяет выполнять вычисления с числами. Хороший пример использования – расчет комиссии продаж для торгового представителя.

    В приведенном ниже примере, торговый представитель по продажам:

    • не получает комиссионных, если объем продаж меньше 50 тыс;
    • получает комиссию в размере 2%, если продажи между 50-100 тыс
    • получает 4% комиссионных, если объем продаж превышает 100 тыс.

    Рассчитать размер комиссионных для торгового агента можно по следующей формуле:

    В формуле, использованной в примере выше, вычисление суммы комиссионных выполняется в самой функции ЕСЛИ . Если объем продаж находится между 50-100K, то формула возвращает B2 * 2%, что составляет 2% комиссии в зависимости от объема продажи.

    Пример 4. Используем логические операторы (AND/OR) (И/ИЛИ) в функции IF (ЕСЛИ) в Excel

    Вы можете использовать логические операторы (AND/OR) (И/ИЛИ) внутри функции для одновременного тестирования нескольких условий.

    Например, предположим, что вы должны выбрать студентов для стипендий, основываясь на оценках и посещаемости. В приведенном ниже примере учащийся имеет право на участие только в том случае, если он набрал более 80 баллов и имеет посещаемость более 80%.

    Вы можете использовать функцию AND (И) вместе с функцией IF (ЕСЛИ) , чтобы сначала проверить, выполняются ли оба эти условия или нет. Если условия соблюдены, функция возвращает “Имеет право”, в противном случае она возвращает “Не имеет право”.

    Формула для этого расчета:

    =IF(AND(B2>80,C2>80%),”Да”,”Нет”) – английская версия

    =ЕСЛИ(И(B2>80;C2>80%);”Да”;”Нет”) – русская версия

    Пример 5. Преобразуем ошибки в значения “0” с помощью функции IF (ЕСЛИ)

    С помощью этой функции вы также можете убирать ячейки содержащие ошибки. Вы можете преобразовать значения ошибок в пробелы или нули или любое другое значение.

    Формула для преобразования ошибок в ячейках следующая:

    =IF(ISERROR(A1),0,A1) – английская версия

    =ЕСЛИ(ЕОШИБКА(A1);0;A1) – русская версия

    Формула возвращает “0”, в случае если в ячейке есть ошибка, иначе она возвращает значение ячейки.

    ПРИМЕЧАНИЕ. Если вы используете Excel 2007 или версии после него, вы также можете использовать функцию IFERROR для этого.

    Точно так же вы можете обрабатывать пустые ячейки. В случае пустых ячеек используйте функцию ISBLANK, на примере ниже:

    =IF(ISBLANK(A1),0,A1) – английская версия

    =ЕСЛИ(ЕПУСТО(A1);0;A1) – русская версия

    ITGuides.ru

    Вопросы и ответы в сфере it технологий и настройке ПК

    Примеры использования функции проверки условия (ЕСЛИ) в Excel

    Функция ЕСЛИ относится к логическим функциям Microsoft Excel и является одной из наиболее часто используемых в работе. С помощью этого оператора можно выполнять различные задачи, когда необходимо сравнить какие-то данные и выдать результат. Функция ЕСЛИ в Excel дает возможность использовать в работе ветвящиеся алгоритмы, строить дерево решений и т.д.

    Видео по использованию функции ЕСЛИ в Excel

    Примеры использования оператора ЕСЛИ

    Функция ЕСЛИ выглядит следующим образом:

    =ЕСЛИ (выражение; истина; ложь).

    А теперь немного подробнее:

    1. Выражение — это логическое выражение, которое может быть числом или фразой. Например «10» — это логическое выражение, «без НДС» — тоже логическое выражение. Это единственный параметр, который заполняется в обязательном порядке.
    2. Истина — значение, которое будет выдано в качестве результата, если выражение окажется истинным.
    3. Ложь — значение, которое будет выдано, если выражение будет ложным.

    Простейший пример реализации функции ЕСЛИ в Excel — проверяем равенство значений двух ячеек

    К примеру, можно ввести в поле C1 цифру 8, а в поле D1 написать так: =ЕСЛИ(C1 );

  • меньше ( =);
  • меньше или равно ( ).
  • Примеры функций И, ИЛИ

    Также при использовании в Экселе функции ЕСЛИ есть возможность соединить ее с простыми операторами сравнения (вроде И, ИЛИ). Например, можно написать такое условие: =ЕСЛИ(И(A1 3); «проходит», «не проходит»). Получается следующее условие: если оценка студента меньше или равна 5 и больше 3, то будет показан комментарий «проходит», в противном случае — «не проходит» (проходят только те студенты, у которых в оценках стоят четверки и пятерки).

    Читать еще:  Автоматическая нумерация в word

    Более сложный пример использования функции ЕСЛИ — с использованием условий И либо ИЛИ

    Следующее условие с примером оператора ИЛИ: =ЕСЛИ(ИЛИ(A1=5; A1=10); 100; 0). Получается, что если число в ячейке А1 равняется 5 или 10, то программа выдаст 100, в противном случае — 0.

    Кроме того, можно применять эти простые операторы и для решения более сложных задач. Например, в базе данных необходимо отобрать должников, которые должны более 10 тысяч рублей и уже не платили более 6 месяцев. Если программа найдет такого человека, то пусть выдаст критерий «проблемный заемщик».

    Допустим, в ячейке A1 находится информация о сроке задолженности (в месяцах), а в поле B1 — сумма задолженности. Тогда формула будет выглядеть следующим образом: =ЕСЛИ(И(A1>=6; B1>10000); «проблемный заемщик»; «»). Если будет найден человек, который подходит под указанное условие, то программа напишет напротив его фамилии комментарий «проблемный заемщик», в противном случае ячейка останется пустой.

    Если один из параметров считается критическим, тогда можно составить формулу так: =ЕСЛИ(ИЛИ(A1>=6; B1>10000); «критическая ситуация»; «»). Если программа найдет совпадения хотя бы по одному параметру (либо срок, либо сумма задолженности), то пользователь увидит сообщение о том, что ситуация критическая. Разница с предыдущей формулой в том, что в первом случае сообщение «проблемный заемщик» выдавалось только тогда, когда выполнялись оба условия.

    Другие примеры использования оператора ЕСЛИ

    Функцию ЕСЛИ можно использовать для обхода встроенных ошибок деления на ноль, и еще в ряде случаев

    Очень часто в Экселе возникает такая ошибка, как «ДЕЛ/0», т.е. деление на 0. Как правило, она появляется в техслучаях, когда копируется формула «A/B», а число B в некоторых ячейках равняется нулю. Этого можно избежать, если использовать оператор ЕСЛИ. Для этого необходимо написать так: =ЕСЛИ(B1=0; 0; A1/B1). Получается, что если в ячейке B1 будет ноль, то Excel сразу же выдаст ноль, в противном случае программа поделит A1 на B1 и выдаст результат.

    Еще одна ситуация, которая довольно часто встречается на практике, расчет скидки в зависимости от общей суммы покупки. Для этого понадобится примерно такая матрица:

    • до 1000 — 0%;
    • от 1001 до 3000 — 3%;
    • от 3001 до 5000 — 5%;
    • свыше 5001 — 7%.

    К примеру, в Excel есть условная база данных клиентов и информация о том, сколько они потратили на покупки. Задача состоит в том, чтобы рассчитать для них скидку. Для этого можно написать так: =ЕСЛИ(A1>=5001; B1*0,93; ЕСЛИ(А1>=3001; B1*0,95;..). Суть ясна: проверяется общая сумма покупок, и когда она, к примеру, больше 5001 рублей, то умножается на 93% стоимости товара (ячейка B1*0,93), когда больше 3001 рублей, то умножается на 95% стоимости товара и т.д. Такую формулу легко можно использовать и на практике: уровень объема продаж и уровень скидок устанавливается на ваше усмотрение.

    Таким образом, применять функцию ЕСЛИ можно практически в любой ситуации, функциональность Microsoft Excel это позволяет. Главное — правильно составить формулу, чтобы результат не оказался ошибочным.

    Отблагодари меня, поделись ссылкой с друзьями в социальных сетях:

    Функция ЕСЛИ() в EXCEL

    Функция ЕСЛИ() относится к наиболее часто используемым функциям.

    Синтаксис функции

    ЕСЛИ(лог_выражение;значение_если_истина;[значение_если_ложь])

    Лог_выражение — любое значение или выражение, принимающее значения ИСТИНА или ЛОЖЬ. =ЕСЛИ(A1>=100;»Бюджет превышен»;»ОК!») Т.е. если в ячейке A1 содержится значение большее или равное 100, то формула вернет ОК!, а если нет, то Бюджет превышен .

    В качестве аргументов функции, могут участвовать формулы, например: =ЕСЛИ(A1>100;СУММ(B1:B10);СУММ(C1:C10)) Т.е. если в ячейке A1 содержится значение >100, то суммирование ведется по столбцу B , а если меньше, то по столбцу С .

    Вложенные ЕСЛИ

    В EXCEL 2007 в качестве значений аргументов значение_если_истина и значение_если_ложь можно для построения более сложных проверок использовать до 64 вложенных друг в друга функций ЕСЛИ() . =ЕСЛИ(A1>=100;»Бюджет превышен»;ЕСЛИ(A1>=90;»Крупный проект»;ЕСЛИ(A1>=50;»Средний проект»;»Малый проект «)))

    Вышеуказанную формулу можно усложнять и дальше, но есть другие подходы:

    Для функции ВПР() необходимо создать в диапазоне A3:B6 таблицу значений:

    Если требуется вывести разный текст в случае наличия в ячейке А1 отрицательного значения, положительного значения или 0, то можно записать следующую формулу:

    или, если требуется вместо текстовых значений вывести формулы, можно использовать ссылки на диапазон ячеек (содержащих формулы)

    =ПРОСМОТР(A24;<-1E+307;0;1E-307>;A27:A29) (см. файл примера )

    Опущен третий аргумент [значение_если_ложь]

    Третий аргумент функции не обязателен, если его опустить, то функция вернет значение ЛОЖЬ (если условие не выполнено). =ЕСЛИ(A1>100;»Бюджет превышен») Если в ячейке A1 содержится значение 1, то вышеуказанная формула вернет значение ЛОЖЬ.

    Вместо ИСТИНА или ЛОЖЬ в первом аргументе введено число

    Т.к. значение ЛОЖЬ эквивалентно 0, то формулы =ЕСЛИ(0;»Бюджет превышен»;»ОК!») или (если в ячейке A1 содержится значение 0) =ЕСЛИ(A1;»Бюджет превышен»;»ОК!») вернут ОК!

    Если в ячейке A1 находится любое другое число кроме 0, то формула вернет Бюджет превышен . Такой подход удобен, когда проверяется равенство значения нулю.

    Связь функции ЕСЛИ() с другими функциями использующие условия

    EXCEL содержит также другие функции, которые можно применять для анализа данных с использованием условий. Например, для подсчета количества вхождений чисел в диапазоне ячеек используется функция СЧЁТЕСЛИ() , а для сложения значений, удовлетворяющих определенным условиям, используется функция СУММЕСЛИ() .

    Функция ЕСЛИ() , как альтернативный вариант, может быть также использована для подсчета и сложения значений с использованием условий. Ниже приведены иллюстрирующие примеры.

    Пусть данные находятся в диапазоне A6:A11 (см. файл примера)

    Подсчитаем сумму значений, которые больше 10 с помощью функции СУММЕСЛИ() , записав =СУММЕСЛИ(A6:A11;»>10″) . Аналогичный результат (23) можно получить с помощью формулы массива =СУММ(ЕСЛИ(A6:A11>10;A6:A11)) (для ввода формулы в ячейку вместо ENTER нужно нажать CTRL+SHIFT+ENTER )

    Теперь подсчитаем количество вхождений чисел больше 10 в диапазоне ячеек A6:A11 =СЧЁТЕСЛИ(A6:A11;»>10″) . Аналогичный результат (2) можно получить с помощью формулы массива =СЧЁТ(ЕСЛИ(A6:A11>10;A6:A11))

    Теперь, когда принцип понятен, с помощью функции ЕСЛИ() можно конструировать и другие формулы с условиями. Например, нахождение минимального значения среди чисел больше 10: =МИН(ЕСЛИ(A6:A11>10;A6:A11))

    Ссылка на основную публикацию
    Adblock
    detector